UPS PICo HV3.0A no lights at all

Support for the UPS PIco HV3.0A

UPS PICo HV3.0A no lights at all

Postby joti76 » Sat May 13, 2017 10:32 pm

Hi, i have powered my pi on the pins with 5v 5A power supply, but no lights at all are On at the pico,
i can access the pico status for a view seconds then it goes to sleep(i think).
When i reset the pico 4 lights are lights are blinking (orange, green blue and the chg blue light) and i can access the status again.
Attachments
IMG_1969.JPG
IMG_1969.JPG (143.49 KiB) Viewed 1045 times
IMG_1968.JPG
IMG_1968.JPG (130.16 KiB) Viewed 1045 times
pico.png
pico.png (11.69 KiB) Viewed 1045 times
joti76
 
Posts: 4
Joined: Sat May 13, 2017 9:55 pm

Re: UPS PICo HV3.0A no lights at all

Postby Pimaster » Sun May 14, 2017 2:53 pm

Hi,
Have you installed Daemons on the Raspberry Pi ?
This must be done.
Please advise
Warmest Regards
PiM
---
Designing with Mentor Graphics PADS - www.pads.com
Please read and follow the PiForum rules
http://www.forum.pimodules.com/viewtopic.php?f=13&t=196
---
Pimaster
Site Admin
 
Posts: 1584
Joined: Fri Sep 14, 2012 7:50 am

Re: UPS PICo HV3.0A no lights at all

Postby joti76 » Sun May 14, 2017 5:48 pm

Hi, i have followed this instructions http://www.pimodules.com/_pdf/Ultra%20S ... aemons.pdf

and service picofssd status
Attachments
pico2.png
pico2.png (12.64 KiB) Viewed 1038 times
joti76
 
Posts: 4
Joined: Sat May 13, 2017 9:55 pm

Re: UPS PICo HV3.0A no lights at all

Postby joti76 » Sun May 14, 2017 10:03 pm

Hi again, finally i have made a new clean rasbian install and used the "automated install script" from Siewert30SW.
Now when the raspberry is plugged in only the CHG light is on, when i plugged it off, it
stays on battery and shuts down in a minute or so.

How can i check if the pico is correctly shutting down the raspberry?
And if the RTC is working?

Thanks!!
Attachments
pico3.png
pico3.png (10.5 KiB) Viewed 1010 times
joti76
 
Posts: 4
Joined: Sat May 13, 2017 9:55 pm

Re: UPS PICo HV3.0A no lights at all

Postby mivo » Wed May 17, 2017 2:55 pm

joti76 wrote:Now when the raspberry is plugged in only the CHG light is on, when i plugged it off, it
stays on battery and shuts down in a minute or so.

Hi,

LED labeled "UPS" should blink in normal operation - if it's not disabled by register. Please check register LED_OFF by this command
Code: Select all
i2cget -y 1 0x6b 0x15


Output should be 0x00 or 0x01

joti76 wrote:How can i check if the pico is correctly shutting down the raspberry?

You can watch shutdown process on console or SSH session by this command
Code: Select all
sudo journalctl -f

It will watch and output system log entries, including PICOFSSD detected UPS on battery (after 1 min. by default) and shutdown sequence, until disconnect or system halt.
My toys:
Raspberry Pi 3 + UPS PIco HV3.0 A Stack
Minibian (Raspbian Jessie) + Domoticz beta

RaZberry module + 2x Comet Z-Wave + Z-wave socket
WeMo Switch
mivo
 
Posts: 25
Joined: Fri Apr 21, 2017 9:11 pm
Location: Czechia

Re: UPS PICo HV3.0A no lights at all

Postby mivo » Thu May 18, 2017 7:21 am

Simple answer regarding RTC - try to read currrent time with:
Code: Select all
sudo hwclock -r

If RTC working correctly, it should output time without errors. To set RTC time to current OS time (output of date command), start
Code: Select all
sudo hwclock -w

There are probably some interaction issues of fake-hwclock and NTPD time sync (both installed by default in Raspbian) with RTC, when not connected to internet. Not so important for me on my system, so not discovered it deeply yet.

Try this post or search forum regarding RTC
viewtopic.php?f=26&t=3259
My toys:
Raspberry Pi 3 + UPS PIco HV3.0 A Stack
Minibian (Raspbian Jessie) + Domoticz beta

RaZberry module + 2x Comet Z-Wave + Z-wave socket
WeMo Switch
mivo
 
Posts: 25
Joined: Fri Apr 21, 2017 9:11 pm
Location: Czechia

Re: UPS PICo HV3.0A no lights at all

Postby joti76 » Fri May 19, 2017 5:52 pm

Using the command "i2cget -y 1 0x6b 0x15"
i get 0xff

So i tried
i2cset -y 1 0x6b 0x15 0x01

and
i2cset -y 1 0x6b 0x16 0x01

Now UPS Led is blinking and battery led goes on on battery power.

Thanks!!!
joti76
 
Posts: 4
Joined: Sat May 13, 2017 9:55 pm


Return to UPS PIco HV3.0A

Who is online

Users browsing this forum: No registered users and 1 guest